Exploring Additional Authoring Techniques in Dreamweaver
DW-II Lab
Overview:      Having completed an overview of the Dreamweaver basics, we now rum our attention to some additional features that you are likely to use frequently. We will consider formatting web pages using tables and also learn about image rollovers, imagemaps, and other active page elements.
Before beginning: Dreamweaver requires you to organize your site inside your local root folder (that you created last lab).  You must let Dreamweaver know where your site is located (You need to choose "New Site" in the Site menu)
Open Dreamweaver and choose Site>New Site. Name the site as you like; and answer the various questions (ie Select "No server technology"; "None" for LAN option; etc) You MUST choose your site folder as the site's Local Root Folder, Remember to properly set your site each time you use Dreamweaver!
1. Tables in Dreamweaver
Tables are used in web pages to provide formatting options that are not available using other HTML tags. For example, placing information side-by-side is somewhat difficult without tables. Tables can be used for mixing images beside text or creating 'columns' as well as other formatting needs.
la. From the desktop of Windows, find the class OUT folder and copy the contents of the folder labeled DWIIFiles to the same folder that your files from the first Dreamweaver lab are in (Bob's Demonstration or something similar). Images should go in your images folder.
1b. Use Dreamweaver to create a new html file: File menu > New option; Select "Blank Page" and then "HTML". Click Create. Give your blank page a title (like "Monthly Activities") and text (formatted as a header 1) like "Coming Events" and then save this file as calendar.html
The method used for creating tables is really quite simple. Let's create a table representing a simple calendar for this month:
1c. Position the cursor below the "coming Events" and select Table from the Insert menu. We'll need seven rows - one for the month name, one for the day names, and five for the dates of the month. We'll need seven columns as well. Set the table Border thickness to 2. Enter these figures and then click OK. A blank table will appear on your page.
Filling in the data is remarkably easy. Just think of each table cell as a distinct Web page. Anything you want to put in there you can.
1d. Click in the first cell on the second row. Type in Sunday, center it and make it bold. Then increase the point size. (Choose 14 pt in the Size box in the "Properties" window.) Enter and format the rest of the names of the days of the week across this row.
le. Enter the numerical dates of the month. Jan 1st was a Thursday.
1f. Presumably you'd like to center all of the days and dates, but you'd rather not have to click on each one individually. Fortunately, there is a shortcut. To center all of the data, first highlight all the cells in the table by clicking and dragging the mouse from the upper left hand cell to the lower right hand cell. Then click on the center align button in the Properties window. That's all.
Non-standard table structure
In our example, we still have to add a month name. We could stick it in the middle cell of the first row, but as we've seen, that could cause the whole middle column to expand and look awkward. What we'd rather do is modify the first row so that it contains only one cell spanning all seven columns.

1g. Do this by first selecting the entire first row of the table with the mouse. Then look in the bottom half of the Properties panel. (You may need to click on the downward-pointing triangle arrow in the lower-right corner.) Click, the Merge Cells button (immediately below the word "Row" in the Properties panel). Note the effect. The first cell now spans 7 columns as requested.
1h. Enter the current month and year in the cell, center it and make it a level one header. Tidying up
There are many additional formatting features of tables that allow you to design them to your tastes. For instance, tables can be centered on the page. In addition, you can choose specific widths and heights for rows and columns, respectively, set the width of the table border, specify the space between cells, and the space which surrounds the cell contents. You can also change the colors.
To do any of these things, you'll first have to select the table, which you can do by moving the cursor over any corner of the table, until it turns into a small table icon. Click to highlight the entire table. Then look in the Properties window for things you can change.
li. Change the width of the table to 90%. (i.e. 90% of the width of the browser - the actual width will depend on the size of whatever browser opens this page) Preview this change — test the 90% table by changing the browser window size.
1j. Center the table on the page using the Align option.(Make sure you select the entire table!)
1k. Experiment with the "Border", "CellPad" and "CellSpace" options to see what they do. What is a border of 0? Finally, set the border to 3, spacing to 3 and padding to 8.
11. Experiment with setting different background colors for the table (Bg color), and for the border
(Brdr color) before setting the background color to pale green and the border color to hexadecimal
RGB values: #003300. 1m. You can also change the properties of individual cells. Place your cursor in a (any) special date (or
make-up a holiday) and give it a dark blue background with white text. In. Save the page and preview it. Resize your browser window and notice how the formatting changes
automatically based on browser (client) attributes.
lo. Return to Dreamweaver. For practice, select two side-by-side cells and merge them Ip. As a further example, select two vertically adjacent cells and merge them. Hopefully you get the
idea of the flexibility of tables.
2. Web layout design using tables	
The data that is displayed in the cells of a table need not be just numbers and/or	
text. Images can be incorporated, as can links and even other tables. Tables	\
have become a very effective tool for the creative design of Web pages.	
Consider the Furman University home page (www.furman.edu). This page	
actually uses a number of tables, including tables-within-tables.	
2a Try this simple exercise: create a new page and add a 2-row, 2-Column table. Save this file as layout.html. Type some HI header text in the upper left-hand corner. Place the dog.jpg image in the lower left-hand corner. Add an unordered list in the lower right hand corner.
2b Change the table's border to zero. Shrink the size of the images and table so that it all fits neatly on in about half the window.
2c In the upper right cell, insert a 3-row, 2-column table. Add a word or two in each of the rows in the first column. Now, merge the entire second column into one cell and add the test.gif image to that cell. Make sure the total size is still about Va page
2d Finally, at the bottom of this page, add a text link to your calendar.html page before saving.
3. Fun with Images - Imagemaps
A topic that we have not yet discussed is that of creating imagemaps. An imagemap is an image that contains "hot spots" - regions of the image which can be clicked -on to link to some other Web URL. With Dreamweaver's imagemap editor, creating imagemaps is easy.
3a. Open your layout.html page. Add the campusmap.gif image below the table and resize it (if needed) to be about 600 x 300 pixels.
3b. Click once on the image to highlight it. Then take a look at the Properties window for the Map options - in the lower left. (If necessary, click on the downward pointing triangle arrow in the lower right corner. This will expose the imagemap options that you need to use.) Click on the "Oval Hotspot Tool".
3c. The cursor becomes a small crosshair icon. Use this to drag a quarter-sized (25e") circle around the bell tower in the image. If you need to adjust the size or position of the oval, return to the Properties window and click on the "Pointer Hotspot Tool" (the one with the black arrow on it). You can use this to move the hotspot or reshape it.
3d. With the hotspot selected (bright blue), the Properties window will show all the hotspot properties. One of these hotspot properties is a link. In the "Link" box, remove the "#" and enter
http://www.furman.edu
3e. Use the same basic procedure to draw a 1" rectangular hotspot around the Plyler Hall/Riley Hall area, and use the URL http: //www. furman.edu/riley
3f. Save and preview the page. Note that the hotspots are invisible, but they do what you expect when you click on them.
Other hotspot shapes are available as well. And remember that you can always reshape and move existing hotspots if you like.
Image rollovers
Many buttons on web pages "react" to your mouse movement - if you 'mouse over' the image, it changes. This is called an image rollover, because the image changes when the mouse "rolls over" it. Let's try it out with a silly little example.
3g. Go to our class web site and find the class roster images. Copy your own picture and one other image to your Web site images folder. Rename files if needed.
3h. Open the layout.html page and remove the original 'Homer' image from the upper-right of the table. Position the cursor in this table cell. Choose Insert>Image Objects>Rollover Image.
3i. You'll be asked for three important pieces of information. First, name the image something like "Classpics". Giving the picture a name is important if you're going to do something more complicated with it. Click Browse to choose one of the images that you downloaded as your "Original Image" and one for your "Rollover Image". "Preload Images" should be checked, and there is no need to enter a "When clicked" URL for this example. (Though you should note that you could...)
3j. Click OK. Save the page and preview it. SOME browsers warn about a security issue - you can "Allow Blocked Content" if asked. Move the mouse over the image, it should change.
We don't have to concern ourselves too much with how this works - yet. But you should be aware that what's being used here is Javascript. Javascript is a programming language that you can use on Web pages to detect when certain events happen (like mouse rollovers, mouse clicks, etc.) and react to them by moving things around on the page, swapping pictures, and so on. Take a look at the head section of the HTML source of your rollover page if you would like to see what the Javascript code looks like. We will discuss this more closely later in the term.

4. Generalizing: Dreamweaver Behaviors
As the preceding discussion suggests, Javascript is an extremely powerful tool. It is made even more powerful by the fact that Dreamweaver generates it for us! That's what we'll explore next -Dreamweaver Behaviors.
A behavior basically involves an event that causes some action.
This is the basic idea of Behaviors in a nutshell: Anything that you can put on a Web page - text, images, tables, table cells, links, etc. - can be given a name. Once you name something, you can refer to it by that name. Furthermore, all of these Web page objects have properties associated with them. For instance, images have a source (where the image is stored). Table cells have a background color. A section of text has a font, color, style, etc.
If you can refer to something by name, you can define an action that changes some of its properties when the viewer does some event (mouse click, etc). For example, you can:

· make the source of an image change when the mouse rolls over it (an image rollover)
· change the background color of a table cell when a certain button is clicked
· change the font and color of some text when a key is pressed.

Each of these is an example of a Behavior - an event/action pair that you define.
Behaviors are a bit complicated at first, but once you "get it" you'll be able to do incredible things on your Web pages. Take your time on this section! And ask lots of questions. We'll just do a couple of interesting tasks, but what I hope you get out of it is an appreciation for how many different types of behaviors could be defined.
Explicit Rollovers Using Behaviors
To get started with a simple example, let's create another rollover image manually, NOT using the Dreamweaver Rollover Image feature. You can use the same two images that you used before, or you can choose two different ones.
4a. Create a new page in Dreamweaver and save it as temp.html. Insert one of your images. Do not use Insert>Image Objects> Rollover Image —   Use Insert>/mage instead.
4b. Click once on the image to highlight it. Then go to the Properties window and look in the lower-left for a text box next to the thumbnail copy of your image ~ this is for the image name. Give this the
4c. Next, click on the Tag Inspector tab (upper-right of your screen - if it isn't there, use the menu Window»Tag Inspector to display it). To define a new behavior for this image, select the
Behavior tab and click once on the + button. You'll see a list of possible behaviors. Choose "Swap Image".
4d. The image that you just named should be highlighted in the "Images" box. If not, highlight it. Then click Browse to select the image that will replace this one.
4e. Make sure that "Preload Images" and "Restore Image onMouseOut" are both checked. Then click OK.
You've just defined a behavior for your image! Two of them, to be precise. Look in the Behavior window. You'll see that two Event/Action pairs are listed alphabetically. Here's what they mean:
· onMouseOver -When the mouse goes over the image, something happens: Here, a swap
image action will occur;
· onMouseOut - When the mouse leaves the image, something happens: Here, a restore
action (Swap Image Restore) will occur, putting the original picture back.
6f. Save the page and preview it. Move the mouse over your new image.
"Big deal!" you might be saying. "I already knew how to do a rollover!" True, but now you see how to do it using behaviors. 

Concepts Learned:
· Using tables to format web pages
· Image maps
•   Dreamweaver behaviors 
What you should have created:
· New files: calendar.html, layout.html
· layout.html should have a roll-over image and image map. Also a link to your calendar page.
index.html	calendar.html	layout.html
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